Version 9.13.8

      Version 9.13.8

      Hi @Slait

      Manchmal hängt mein Char wenn er den Alten mann anspricht und porten will ( wenn ich eine Movement taste drücke Pfeiltaste, wasd portet er dann) War in einer alten version auch.

      Wenn mein char stribt und ein anderere spieler nähert sich steht mein Char auf wartet auf die % HP oder Used buffskill dann greift erst der Anti bann und er changed channel.

      In version 9.13.5 hat der "Anti bann Channel changer wenn spieler anwesend " mit "wenn bot 10x gekickt wird X min warten bis relog" zsm gearbeitet auf diese funktion habe ich schon sooooo lange gewartet ... nun ist es wieder wie beim Alten und der Char loggt nicht ein wenn auf allen Channeln jmd ist. ( char ist wieder Online, kann leider nicht sagen was passiert ist ob da nun doch ein Timer eingebaut ist oder das metin fenster abgekackt ist, sorry )
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?

      Post was edited 2 times, last by “ZeigMalSchnegge” ().

      Sorry so ganz verstehe ich die Frage nicht...also es geht darum, dass der Char nicht direkt CH wechseln soll, sondern erst wenn er volles Leben hat in dem Fall?
      Also da wurd aber nichts anders was diesen Code betrifft, sicher, dass es nicht evtl. Zufall war sondern sicher mit der Version 9.13.5 und 9.13.16 zusammenhängt?


      If you want to support the work of us, please renew/activate your uploaded.net premium account with the following link:
      >>> ul.to/ref/13987238 <<<
      @Slait das sind 3 Verschiedene Punkte.

      Der Char Stirbt und soll direkt den Channel wechseln, wenn sich ein Spieler nähert. Das macht der Bot nicht. Der Bot steht auf Wartet bis die min % zahl an HP erreicht ist bez wartet bis Starker Körper einsetztbar ist und wechselt dann erst den Channel .

      __________________________________
      " In version 9.13.5 hat der "Anti bann Channel changer wenn spieler anwesend " mit "wenn bot 10x gekickt wird X min warten bis relog" zsm gearbeitet auf diese funktion habe ich schon sooooo lange gewartet ... nun ist es wieder wie beim Alten und der Char loggt nicht ein wenn auf allen Channeln jmd ist. ( char ist wieder Online, kann leider nicht sagen was passiert ist ob da nun doch ein Timer eingebaut ist oder das metin fenster abgekackt ist, sorry ) "

      Unter Anti Bann -> Time Setting -> After X relogs wait X min before loggin in soll mit Channel Change wenn Spieler Anwesend. Zusammen Arbeiten das hat in Version 9.13.5 auch funktioniert.
      9.13.5 =
      Spieler nähert sich botchar , botChar wird gekickt und switcht alle channel durch dabei ist es Ihm egal ob alle channel voll sind er funktioniert mit ->>>>> after 10 relogs wait 1min before loggin in . Der bot reloggt also 10x und macht dann eine Pause von 1min ( weil wie gesagt in jedem channel 1^spieler anwesend ist )

      Früher als 9.13.5 und nun auch wieder bei 9.13.8 =
      Spieler nähert sich botchar , botChar wird gekickt und switcht alle channel durch Bot merkt das in jedem Channel 1 Spieler ist und freezed

      Thread vom 13. Aug 2018 ( gleiche thematik )
      Alchemist not found | Tempel Chars laufen nicht zu Gemi | Player Detector

      Zitat " Player detector ~ Meine Bots laufen auf Antibann einstellungen egal wo. Ich stelle ein wenn ein Spieler anwesend ist soll er den Channel wechseln, manchmal kommt der Char dadurch in einen komischen loop, Metin2 Fenster zeigt login screen flakkert alle 3 sek ."


      _________________________________
      Manchmal hängt mein Char wenn er den Alten mann anspricht und porten will ( wenn ich eine Movement taste drücke Pfeiltaste, wasd portet er dann) War in einer alten version auch.

      Nachtrag 15.03 Charakter ist halb unsichtbar und hängt seit 30min im portal fest und m2bob checkts nicht.

      _____________________________________

      Hab eine Rechtschreibfehler schwäche ( LRS ) deshalb kann es sein das ich so durcheinander schreibe vorallem wen ich gestresst bin und wenig zeit habe . Tut mir leid ich bemühe mich
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?

      Post was edited 1 time, last by “ZeigMalSchnegge” ().

      Okay, also diese zwei Funktionen können wir anschauen :)
      Die sollten eigentlich schon "zusammenarbeiten", wenn ich deinen Punkt korrekt verstanden habe.
      Wieso das plötzlich nicht mehr der Fall ist macht garkeinen Sinn für mich, aber wir testen es gerne mal.


      If you want to support the work of us, please renew/activate your uploaded.net premium account with the following link:
      >>> ul.to/ref/13987238 <<<

      Slait wrote:

      Mögliche Ursachen:
      - Virenscanner
      - Dateien beschädigt
      [HOW-TO] Problem solving (Gameforge servers)
      Bei beiden sollte das eig. helfen :)
      Oder schau einfach was du gemacht hast bevor der Fehler bei dir kam...zB Programme installiert oder so



      Neue vm, alles geupdated, frische ordner


      ergo es liegt entweder an zu wenig CPU leistung oder ram

      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?

      Post was edited 3 times, last by “ZeigMalSchnegge” ().

      @Slait hab alles so wie du geschrieben hast gemacht ..
      +
      Neue vm, alles geupdated, frische ordner
      Virus programm ist auch aus

      und hab nur 3 clienten laufen obwohl die VM 12 clients schafft und trotzdem kommt der error...

      hab auch wieder da problem das dass bot fenster ewig braucht zum injecten bez gar nicht injected und die clients als neustarten
      und manchmal loggen die bots nicht ein dann muss ich mehrmals den kompletten m2bob client neustarten bis accounts einloggen
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?

      Post was edited 3 times, last by “ZeigMalSchnegge” ().

      Also wenn der 3 Clients schafft, hast du mal auf die CPU Auslastung geschaut? User im Metinforum haben sich beschwert, dass Metin viel CPU fressen soll seit dem.
      Oder wie ist es wenn du testweise zB auf .sg deine Clients einloggst, wenns da noch geht muss es eigentlich am Client von .de an sich liegen, weil Bob ist ja die gleiche version...


      If you want to support the work of us, please renew/activate your uploaded.net premium account with the following link:
      >>> ul.to/ref/13987238 <<<
      @Slait Bitte genauer lesen das problem besteht immer noch mit dem error hab alles neu installiert virus scanner aus etc ... es gibt immer noch probleme beim

      - Einloggen
      - Bot fenster inject
      - ERROR MELDUNG : Virtualallocex

      Es liegt nicht am user ... dieses problem haben mehrere leute deshalb bottet fast keiner mehr auf einer Virtuellen Maschine.

      ZeigMalSchnegge wrote:

      @Slait hab alles so wie du geschrieben hast gemacht ..
      +
      Neue vm, alles geupdated, frische ordner
      Virus programm ist auch aus

      und hab nur 3 clienten laufen obwohl die VM 12 clients schafft und trotzdem kommt der error...

      hab auch wieder da problem das dass bot fenster ewig braucht zum injecten bez gar nicht injected und die clients als neustarten
      und manchmal loggen die bots nicht ein dann muss ich mehrmals den kompletten m2bob client neustarten bis accounts einloggen
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?
      Installier dir eine VM mach windows updates mach defender aus metin2 und m2bob download und teste es selbst ...
      wirst sehen spätestens nach 6std haste auch den error
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?
      @Slait nächstes szenario:null
      Bei Quickstart ist der Haken bei : " Wenn clients gestartet sind automatisch hidden"
      diese funktioniert hat bei mir nicht funktioniert.

      ergo:
      Patcher neu runtergeladen , neuer ordner aufn desktop patcher rein , defender aus, durchgepatcht, eingeloggt, metin2 fenster plobbt auf ( um auth IP und Ch IP zu ziehen, HAT NICHT FUNKTIONIERT )
      musste somit Manuell einloggen, hab dann 6 accounts in 1-6 slot eingetragen auf Quick start gedrückt und Clients starten zwar aber nicht Hidden und meine Onboard graka raucht fast ab :)

      Windows und Updates usw alles aktuell... Version 1809

      Nachtrag : wenn ich den Haken bei " press play ( when ingame) aktiviere starten die Clients im Hidden modus ..
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?
      Hast du denn eine Möglichkeit den Error schneller zu reproduzieren?
      Ich glaube du merkst selbst, dass wir nichts fixen können wenn der "1x alle 6 Stunden" kommt...eine Windows XP VM zum testen habe ich hier schon :)
      Würde es helfen, wenn wir einfach es so einbauen, das wenn der Error kommt, er nach 3sek Metin2 beendet und es nochmal versucht?


      If you want to support the work of us, please renew/activate your uploaded.net premium account with the following link:
      >>> ul.to/ref/13987238 <<<

      Slait wrote:

      Hast du denn eine Möglichkeit den Error schneller zu reproduzieren?
      Ich glaube du merkst selbst, dass wir nichts fixen können wenn der "1x alle 6 Stunden" kommt...eine Windows XP VM zum testen habe ich hier schon :)
      Würde es helfen, wenn wir einfach es so einbauen, das wenn der Error kommt, er nach 3sek Metin2 beendet und es nochmal versucht?


      Ja, wenn der Error weg geklickt wird kommt das noch 2-3x dann läuft wieder alles für paar stunden. Und dann fängt das Chaos wieder an.
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?
      Aber wenn er "paar mal" kommt und dann es für paar Stunden läuft, wäre es ja trotzdem eine Lösung oder? :)
      Paar mal den Error das dauert dann vllt 30sek - 1min und wenns dann für paar Stunden läuft wäre gut.


      If you want to support the work of us, please renew/activate your uploaded.net premium account with the following link:
      >>> ul.to/ref/13987238 <<<

      Slait wrote:

      Aber wenn er "paar mal" kommt und dann es für paar Stunden läuft, wäre es ja trotzdem eine Lösung oder? :)
      Paar mal den Error das dauert dann vllt 30sek - 1min und wenns dann für paar Stunden läuft wäre gut.


      Der Error kommt auch wenn das Start/stop script ein task ausführt

      Keine Ahnung was du meinst was du oben geschrieben hast aber es wäre gut wenn die Error meldung weg geklickt wird oder der Error gefixxt wird.

      @Slait kannst du auch im Metin Client einstellen das wenn er einloggt die Karte verschwindet ? ( Die karte die man mit "M" Öffnen kann )
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?

      Post was edited 1 time, last by “ZeigMalSchnegge” ().

      @Slait

      Servus,bei version 15.3 Arbeitet der "Channel wechseln wenn spieler anwesend" wieder nicht mit " Wenn bot x Kicks erreicht dann 1min pause "man kommt wieder in einen loop. Wenn spieler anwesend sind



      ´Problem ist schon in älteren versionen aufgetreten deshalb habe ich es auch hier rein gepostet ( siehe post 3 )
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?
      Diese Funktion ist derzeit nur auf GF Servern aktiv (und war schon immer so)...testest du das auf GF Servern oder PServer?
      Falls PServer, kannst du schauen obs auch auf GF Servern buggt? :)


      If you want to support the work of us, please renew/activate your uploaded.net premium account with the following link:
      >>> ul.to/ref/13987238 <<<

      Slait wrote:

      Diese Funktion ist derzeit nur auf GF Servern aktiv (und war schon immer so)...testest du das auf GF Servern oder PServer?
      Falls PServer, kannst du schauen obs auch auf GF Servern buggt? :)


      gf server
      ... mein glück das ich nicht immer direkt patche
      sonst hätte ich den krebs jetzt auf jeden pc.
      _________________________________________________________________________________________________________________________________________________________________
      Dabei
      seit 15'


      ...a never ending story ^^ ?