M2bob CPU PROBLEM !

      Slait wrote:

      @Annabeth Chase I think you misunderstodd me.

      The question is, if this problem occurs with M2Bob only...the source code above there is valid for all servers and causes CPU bugs even without M2Bob :)
      If its only with M2Bob, please give us infos which actions from M2Bob cause these cpu usage bugs to occur.


      Ah , Sory :).How can I understand that? The game is getting excessive CPU problem while entering the game.and after running the game for 5-10 min on average, the same problem is happening.,
      Apart from that, I do not think that a certain function is a problem.Because we tried everything and nothing changed but we'll try a little more.The 2 main problems are happening upon entering the game and after the running the game for a long time


      Hello slait as you said I think some functions are doing the cpu problem Some characters in the picture are reaching the highest level of cpu


      Pickup aktive
      Walhack Akive
      and levelbot aktive
      Mound Mode aktive
      And chracter and gm change aktive


      other function all deaktive

      Check the above functions
      Thanks for the infos so far :)
      Can you try testing M2Bob with some of these features disabled in order to see if one of these is causing it.
      You can also try just standing around (not hitting monsters) and only using Waithack Range and see if high cpu usages are happening


      Slait wrote:

      Okay...the one "running a long time", thats probably the metin client since there is lots of action going on.
      The other bug, just to clarify, to reproduce i just need togo ingame with m2bob and stand around to get it? :O


      Not for it , if ı understand correctly you ask wiht and without m2bob photos , ı wanted to show if there is a problem this. You can see first photo activated Waithack range other disactivaded waithack range.
      We need to isolate the bug features...thats why my question was if this also occurs when just standing around as you said "after the running the game for a long time"...which is bad because its hard to fix
      The Waithack Range is easier to fix, which Range and Strnegth settings do you have? Is it also happening when using the Waithack Range in the Attack tab or just in the general tab?

      PS: please put your photos in spoiler, its so hard to navigate the thread...


      Slait wrote:

      We need to isolate the bug features...thats why my question was if this also occurs when just standing around as you said "after the running the game for a long time"...which is bad because its hard to fix
      The Waithack Range is easier to fix, which Range and Strnegth settings do you have? Is it also happening when using the Waithack Range in the Attack tab or just in the general tab?

      PS: please put your photos in spoiler, its so hard to navigate the thread...


      Waithack range strength 25.I think , when active waithack range , it teleport monster beside.Therefore the cpu is increasing.But main problem like you say "after the running the game for a long time".It's been solved in a common trick, and I hope you can solve it.